summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-05-30 04:57:06 +0900
committerKali Kaneko <kali@leap.se>2013-05-31 03:19:39 +0900
commit4623e6a111193e46a5b86319d3a505f814f024f2 (patch)
treecf9077122bb9cce40e4d7a0f3eb3fec979705aed /debian/rules
parent0ebb159495b941dc40c1f9eaeab250e87edaea7b (diff)
initial debian files
* do not use amalgamation builder * add include dir for libsqlcipher * add libsqlcipher-dev as build-dep
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..401e052
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+# Uncomment this to turn on verbose mode.
+#DH_VERBOSE=1
+
+%:
+ dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_auto_build:
+ python$* setup.py build_sqlcipher
+ python$* setup.py build_py
+
+override_dh_auto_install:
+ python$* setup.py install --skip-build --root=debian/python-sqlcipher \
+ --install-layout=deb
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf build
+ rm -rf docs/_build
+ rm -rf *.egg-info