summaryrefslogtreecommitdiff
path: root/service/setup.py
diff options
context:
space:
mode:
authorBruno Wagner <bwagner@thoughtworks.com>2014-10-16 13:56:11 +0200
committerBruno Wagner <bwagner@thoughtworks.com>2014-10-16 13:56:25 +0200
commite41fba96f1bfb94f079ba5b304ce5331cec39909 (patch)
treedff5bd01fafb632eb8fbd2d981301fdff3608f4b /service/setup.py
parent0de9d8dc31298921f7272d74cdd3c5d4217b5841 (diff)
Pinned versions of all packages, so we can reliably run the upgrade test, also fixed the error we're having on the upgrade test
Diffstat (limited to 'service/setup.py')
-rw-r--r--service/setup.py14
1 files changed, 9 insertions, 5 deletions
diff --git a/service/setup.py b/service/setup.py
index 994e807a..00f5b8d1 100644
--- a/service/setup.py
+++ b/service/setup.py
@@ -19,6 +19,10 @@ import sys
if 'develop' in sys.argv:
sys.argv.append('--always-unzip')
+# next line is a fix to this error that occurs with nose > 1.1.2 and the debian
+# python: http://bugs.python.org/issue15881#msg170215
+import multiprocessing
+
from setuptools import setup
from collections import defaultdict
import os
@@ -69,9 +73,9 @@ setup(name='pixelated-user-agent',
packages=['pixelated', 'pixelated.adapter', 'pixelated.bitmask_libraries', 'pixelated.config', 'pixelated.certificates', 'pixelated.support', 'pixelated.controllers'],
test_suite='nose.collector',
install_requires=[
- 'Twisted',
- 'flask',
- 'requests',
+ 'Twisted==14.0.2',
+ 'flask==0.10.1',
+ 'requests==2.4.3',
'srp==1.0.5',
'dirspec==13.10',
'u1db==13.09',
@@ -80,8 +84,8 @@ setup(name='pixelated-user-agent',
'leap.soledad.client==0.5.2',
'leap.mail==0.3.9-1-gc1f9c92',
'whoosh==2.6.0',
- 'gunicorn',
- 'crochet'
+ 'gunicorn==19.1.1',
+ 'crochet==1.3.0'
],
entry_points={
'console_scripts': [