summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristoph Kluenter <ckluente@thoughtworks.com>2015-08-25 11:44:59 +0200
committerChristoph Kluenter <ckluente@thoughtworks.com>2015-08-25 11:46:20 +0200
commit552a0471a2223f4d48e1a81ad9a51385deafc0ca (patch)
treef673b6dc1af30f3bfe6798e15e660452d83ea724 /debian
parent61447ad3f55f45a404c9602e53bd606b622c8606 (diff)
only use another builddir only if $GO_BUILDDIR is set
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7421b670..195871cf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,6 +7,9 @@
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
+ifdef GO_BUILDDIR
+ export DH_BUILDOPTIONS=--builddirectory=$(GO_BUILDDIR)
+endif
# see FEATURE AREAS in dpkg-buildflags(1)
#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
@@ -19,7 +22,7 @@ include /usr/share/dpkg/default.mk
# main packaging script based on dh7 syntax
%:
- dh $@ --buildsystem pixpybuild --sourcedirectory=service --builddirectory=/tmp/build
+ dh $@ --buildsystem pixpybuild --sourcedirectory=service $(DH_BUILDOPTIONS)
# debmake generated override targets
# This is example for Cmake (See http://bugs.debian.org/641051 )