summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKali Kaneko (leap communications) <kali@leap.se>2018-12-13 19:06:20 +0100
committerKali Kaneko (leap communications) <kali@leap.se>2018-12-13 19:47:12 +0100
commit244d1a3aa5539c8ce4a69ae8695b0621585d7b1c (patch)
tree41544f32f6206f116809a56fe6f0b9142dc1b79f /debian/rules
parent81843a0477c5eba4b3d4f6ff932f748f9e1244e7 (diff)
initial debianization
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4a95be9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+
+export DH_GOPKG = 0xacab.org/kali/getmyip
+export DH_GOLANG_EXCLUDES = vendor
+
+%:
+ dh $@ --with golang --with systemd --buildsystem golang
+
+override_dh_auto_test:
+
+override_dh_install:
+ rm -fr $(CURDIR)/debian/getmyip/usr/share/gocode
+ dh_install
+