summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a7de8f9..776a477 100644
--- a/setup.py
+++ b/setup.py
@@ -138,4 +138,11 @@ setup(
tests_require=tests_requirements,
include_package_data=True,
zip_safe=False,
+
+ extras_require={
+ # needed for leap.common.http
+ # service_identity needed for propper hostname identification,
+ # see http://twistedmatrix.com/documents/current/core/howto/ssl.html
+ 'Twisted': ["Twisted>=14.0.2", "service_identity", "zope.insterface"]
+ },
)