summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorVictor Shyba <victor.shyba@gmail.com>2015-05-27 12:49:44 -0300
committerVictor Shyba <victor.shyba@gmail.com>2015-06-02 19:25:54 -0300
commitc071c69e1b5a0d897674a1f7adc6ff32f19400ff (patch)
tree2a04564aa2ea8f257fc1b3e5a846a6b3cf7a43d7 /setup.py
parent7826a96e526a450380917f9b89e3714576ca50b7 (diff)
[bug] Use BrowserLikePolicyForHTTPS for checking
While testing the way that its implemented now, I found out that no check is being made on certificate attributes against the host. I found this simple way of creating a BrowserLikePolicyForHTTPS using a self signed cert and it worked on my test. I used test_https from Soledad for checking this (which we are fixing on another branch). Also, we don't want to depend on twisted for other things than leap.common.http.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a7de8f9..776a477 100644
--- a/setup.py
+++ b/setup.py
@@ -138,4 +138,11 @@ setup(
tests_require=tests_requirements,
include_package_data=True,
zip_safe=False,
+
+ extras_require={
+ # needed for leap.common.http
+ # service_identity needed for propper hostname identification,
+ # see http://twistedmatrix.com/documents/current/core/howto/ssl.html
+ 'Twisted': ["Twisted>=14.0.2", "service_identity", "zope.insterface"]
+ },
)