summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 5a86973..478d614 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,14 @@
#!/usr/bin/make -f
+NAME=leap-mx
+
%:
dh $@ --with python2 --buildsystem=python_distutils --with=systemd
+override_dh_installinit:
+ dh_systemd_enable -p${NAME} --name=${NAME} ${NAME}.service
+ dh_installinit -p${NAME} --no-start --noscripts
+ dh_systemd_start -p${NAME} --no-restart-on-upgrade
+
override_dh_installchangelogs:
dh_installchangelogs CHANGELOG.rst