summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4263721
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+NAME=leap-mx
+
+%:
+ dh $@ --with python2 --buildsystem=python_distutils --with=systemd
+
+override_dh_installinit:
+ dh_systemd_enable -p${NAME} --name=${NAME} ${NAME}.service
+ dh_installinit -p${NAME} --no-start --noscripts
+
+override_dh_installchangelogs:
+ dh_installchangelogs CHANGELOG.rst