summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authordrebs <drebs@leap.se>2015-04-23 12:23:21 -0300
committerdrebs <drebs@leap.se>2015-04-24 10:55:45 -0300
commitda08ab21bc56a0905db8697032ee1fcbef6298f7 (patch)
treefe962e51725b5e4975c21658dde4d1e111a1db04 /setup.py
parent799703cf884191d097eb5d5316fa964e421683fd (diff)
[pkg] remove initscript from python package
There are some reasons to remove the initscript from the python package: 1. To include the initscript it in the python package it is necessary to assume a lot of things about the system in which the package would be installed. 2. The debian packaging system will correctly create an initscript by itself. 3. We don't have to maintain 2 different setup.py files (one in master/develop branch and another in debian package branches).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 6fec416..3e89eec 100644
--- a/setup.py
+++ b/setup.py
@@ -113,8 +113,7 @@ else:
# be automatically
# placed by distutils, using whatever interpreter is
# available.
- data_files = [("/usr/local/bin/", ["pkg/mx.tac"]),
- ("/etc/init.d/", ["pkg/leap_mx"])]
+ data_files = [("/usr/local/bin/", ["pkg/mx.tac"])]
setup(
name='leap.mx',
version=VERSION,