summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-04-09 23:08:33 +0900
committerKali Kaneko <kali@leap.se>2013-04-09 23:09:06 +0900
commit8fb5895c46282aa913d2cf3c31f3c526174b3f3b (patch)
tree6417a78c8f74aeea1785c997c5c9d0586300b94a /setup.py
Initial import
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..4de7251
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,46 @@
+# -*- coding: utf-8 -*-
+# setup.py
+# Copyright (C) 2013 LEAP
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+"""
+setup file for leap.mail
+"""
+from setuptools import setup, find_packages
+
+requirements = [
+ "leap.soledad",
+ "leap.common",
+ "twisted",
+]
+
+# XXX add classifiers, docs
+
+setup(
+ name='leap.mail',
+ version='0.2.0-dev',
+ url='https://leap.se/',
+ license='GPLv3+',
+ author='The LEAP Encryption Access Project',
+ author_email='info@leap.se',
+ description='Mail Services in the LEAP Client project.',
+ long_description=(
+ "Mail Services in the LEAP Client project."
+ ),
+ namespace_packages=["leap"],
+ package_dir={'': 'src'},
+ packages=find_packages('src'),
+ #test_suite='leap.mail.tests',
+ #install_requires=requirements,
+)