summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-10-30 11:58:22 -0200
committerKali Kaneko <kali@leap.se>2013-10-30 11:59:56 -0200
commit09e6911dc8babf78b228baa0b30111390b622857 (patch)
treeeb3eb366a0733180a77dfdc97bb3732dc142ee9c /setup.py
parent1b66ad707ad4c5111f06d5d230fb65716cbbe949 (diff)
add freeze_debianver_command
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py75
1 files changed, 70 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 57a4164..499a9ee 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,7 @@
"""
Setup file for leap.mail
"""
+import re
from setuptools import setup
from setuptools import find_packages
@@ -46,20 +47,84 @@ trove_classifiers = [
'Topic :: Software Development :: Libraries',
]
+DOWNLOAD_BASE = ('https://github.com/leapcode/leap_mail/'
+ 'archive/%s.tar.gz')
+_versions = versioneer.get_versions()
+VERSION = _versions['version']
+VERSION_FULL = _versions['full']
+DOWNLOAD_URL = ""
+
+# get the short version for the download url
+_version_short = re.findall('\d+\.\d+\.\d+', VERSION)
+if len(_version_short) > 0:
+ VERSION_SHORT = _version_short[0]
+ DOWNLOAD_URL = DOWNLOAD_BASE % VERSION_SHORT
+
+cmdclass = versioneer.get_cmdclass()
+
+
+from setuptools import Command
+
+
+class freeze_debianver(Command):
+ """
+ Freezes the version in a debian branch.
+ To be used after merging the development branch onto the debian one.
+ """
+ user_options = []
+
+ def initialize_options(self):
+ pass
+
+ def finalize_options(self):
+ pass
+
+ def run(self):
+ proceed = str(raw_input(
+ "This will overwrite the file _version.py. Continue? [y/N] "))
+ if proceed != "y":
+ print("He. You scared. Aborting.")
+ return
+ template = r"""
+# This file was generated by the `freeze_debianver` command in setup.py
+# Using 'versioneer.py' (0.7+) from
+# revision-control system data, or from the parent directory name of an
+# unpacked source archive. Distribution tarballs contain a pre-generated copy
+# of this file.
+
+version_version = '{version}'
+version_full = '{version_full}'
+"""
+ templatefun = r"""
+
+def get_versions(default={}, verbose=False):
+ return {'version': version_version, 'full': version_full}
+"""
+ subst_template = template.format(
+ version=VERSION_SHORT,
+ version_full=VERSION_FULL) + templatefun
+ with open(versioneer.versionfile_source, 'w') as f:
+ f.write(subst_template)
+
+
+cmdclass["freeze_debianver"] = freeze_debianver
+
# XXX add ref to docs
setup(
name='leap.mail',
- version=versioneer.get_version(),
- cmdclass=versioneer.get_cmdclass(),
+ version=VERSION,
+ cmdclass=cmdclass,
url='https://leap.se/',
+ download_url=DOWNLOAD_URL,
license='GPLv3+',
author='The LEAP Encryption Access Project',
author_email='info@leap.se',
+ maintainer='Kali Kaneko',
+ maintainer_email='kali@leap.se',
description='Mail Services provided by Bitmask, the LEAP Client.',
- long_description=(
- "Mail Services provided by Bitmask, the LEAP Client."
- ),
+ long_description=open('README.rst').read() + '\n\n\n' +
+ open('CHANGELOG').read(),
classifiers=trove_classifiers,
namespace_packages=["leap"],
package_dir={'': 'src'},