summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index c72965e..27d6c62 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,8 @@ install_binary=install -m 755 -s
VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
build:
+build-arch: build
+build-indep: build
clean:
$(checkdir)
@@ -29,9 +31,11 @@ binary-indep: checkroot
$(install_file) README debian/tmp/usr/share/doc/leap-keyring/
$(install_file) debian/changelog debian/tmp/usr/share/doc/leap-keyring/changelog
$(install_file) debian/copyright debian/tmp/usr/share/doc/leap-keyring/
- gzip -9v debian/tmp/usr/share/doc/leap-keyring/changelog
- gzip -9v debian/tmp/usr/share/doc/leap-keyring/README
+ gzip -9vn debian/tmp/usr/share/doc/leap-keyring/changelog
+ gzip -9vn debian/tmp/usr/share/doc/leap-keyring/README
+ cd debian/tmp && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
+ cd debian/tmp && find . -type f ! -regex '.*DEBIAN/.*' -printf '%P\0' | xargs -r0 sha256sum > DEBIAN/sha256sums
dpkg-gencontrol -pleap-keyring -isp
chown -R root.root debian/tmp
chmod -R go=rX debian/tmp