summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2013-10-28 22:51:11 -0400
committerMicah Anderson <micah@riseup.net>2013-10-28 22:51:11 -0400
commit65bef139a9b1e38d113cff8cfc1134ccbe4ef19e (patch)
treeb7b24386e5300daca42fbb1a80d4de7437feb98b /debian
initial check-in
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control14
-rw-r--r--debian/copyright29
-rw-r--r--debian/postinst7
-rw-r--r--debian/prerm11
-rwxr-xr-xdebian/rules52
6 files changed, 125 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..df5fb61
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,12 @@
+leap-keyring (2013.02.07~leap70+1) wheezy; urgency=low
+
+ * Backport to wheezy.
+ * Add myself to Uploaders.
+
+ -- Micah Anderson <micah@debian.org> Thu, 09 May 2013 16:38:33 -0400
+
+leap-keyring (2013.02.07) unstable; urgency=low
+
+ * Initial version
+
+ -- Micah Anderson <micah@leap.se> Thu, 07 Feb 2013 12:05:28 -0500
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..f25f05c
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: leap-keyring
+Priority: important
+Section: misc
+Maintainer: Micah Anderson <micah@leap.se>
+Standards-Version: 3.9.1
+Uploaders: Micah Anderson <micah@debian.org>
+
+Package: leap-keyring
+Priority: important
+Architecture: all
+Depends: gnupg (>= 1.0.6-4)
+Description: GnuPG archive key of the leap.se repository
+ The riseup repository digitally signs its Release files. This package
+ contains the repository key used for that.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..6e52670
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,29 @@
+This is leap.se's GnuPG keyrings of archive keys.
+
+This package was originally put together by Michael Vogt
+<mvo@debian.org> for Debian and has been adapted to backports.org by
+Alexander Wirt <formorer@debian.org> and for leap.se by
+Micah Anderson <micah@leap.se>
+
+The keys in the keyrings don't fall under any copyright. Everything
+else in the package is covered by the GNU GPL 3+.
+
+Debian support files Copyright (C) 2006 Michael Vogt <mvo@debian.org>
+based on the debian-keyring package maintained by James Troup
+
+Debian support files for debian-archive-keyring are free software; you
+can redistribute them and/or modify them under the terms of the GNU
+General Public License as published by the Free Software Foundation;
+either version 2, or (at your option) any later version.
+
+Debian support files for debian-archive-keyring are distributed in the
+hope that they will be useful, but WITHOUT ANY WARRANTY; without even
+the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
+PURPOSE. See the GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License with
+your Debian system, in /usr/share/common-licenses/GPL, or with the
+Debian GNU debian-archive-keyring source package as the file COPYING.
+If not, write to the Free Software Foundation, Inc., 51 Franklin Street,
+Fifth Floor, Boston, MA 02110-1301 USA.
+
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..c9fb56a
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+set -e
+
+if which apt-key > /dev/null; then
+ apt-key add /usr/share/keyrings/leap-keyring.gpg
+fi
diff --git a/debian/prerm b/debian/prerm
new file mode 100644
index 0000000..17de1b0
--- /dev/null
+++ b/debian/prerm
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+set -e
+
+case "$1" in
+ remove|purge)
+ if which apt-key > /dev/null; then
+ apt-key del 0x1E34A1828E207901
+ fi
+ ;;
+esac
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c72965e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,52 @@
+#!/usr/bin/make -f
+# debian/rules file - for debian/keyring
+
+install_dir=install -d -m 755
+install_file=install -m 644
+install_script=install -m 755
+install_binary=install -m 755 -s
+
+VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+
+build:
+
+clean:
+ $(checkdir)
+ -rm -f foo foo.asc *.bak *~ */*~ debian/files* debian/*substvars
+ -rm -rf debian/tmp
+
+binary-indep: checkroot
+ $(checkdir)
+ -rm -rf debian/tmp
+ $(install_dir) debian/tmp/DEBIAN/
+ $(install_script) debian/postinst debian/tmp/DEBIAN/
+ $(install_script) debian/prerm debian/tmp/DEBIAN/
+
+ $(install_dir) debian/tmp/usr/share/keyrings/
+ $(install_file) keyrings/leap-keyring.gpg debian/tmp/usr/share/keyrings/
+
+ $(install_dir) debian/tmp/usr/share/doc/leap-keyring/
+ $(install_file) README debian/tmp/usr/share/doc/leap-keyring/
+ $(install_file) debian/changelog debian/tmp/usr/share/doc/leap-keyring/changelog
+ $(install_file) debian/copyright debian/tmp/usr/share/doc/leap-keyring/
+ gzip -9v debian/tmp/usr/share/doc/leap-keyring/changelog
+ gzip -9v debian/tmp/usr/share/doc/leap-keyring/README
+
+ dpkg-gencontrol -pleap-keyring -isp
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f keyrings/leap-keyring.gpg
+endef
+
+# Below here is fairly generic really
+
+binary: binary-indep
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot