summaryrefslogtreecommitdiff
path: root/openvpn/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'openvpn/configure.ac')
-rw-r--r--openvpn/configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/openvpn/configure.ac b/openvpn/configure.ac
index 65c639c5..b181f6d6 100644
--- a/openvpn/configure.ac
+++ b/openvpn/configure.ac
@@ -754,7 +754,9 @@ PKG_CHECK_MODULES(
[
have_openssl_ssl="yes"
OPENSSL_SSL_LIBS="-lssl"
- ]
+ ],
+ [],
+ [-lcrypto]
)]
)
@@ -812,13 +814,13 @@ if test "${with_crypto_library}" = "polarssl" ; then
#include <polarssl/version.h>
]],
[[
-#if POLARSSL_VERSION_NUMBER < 0x01020500
+#if POLARSSL_VERSION_NUMBER < 0x01020A00 || POLARSSL_VERSION_NUMBER >= 0x01030000
#error invalid version
#endif
]]
)],
[AC_MSG_RESULT([ok])],
- [AC_MSG_ERROR([PolarSSL 1.2.5 or newer required])]
+ [AC_MSG_ERROR([PolarSSL 1.2.x required and must be 1.2.10 or later])]
)
polarssl_with_pkcs11="no"