summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c089523..1f0b7cf4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,6 +259,12 @@ if test `echo $version | ${AWK} "{print \\$2}"` -eq 6; then
fi
fi
+has_crypto=`${ERL} -eval "case application:load(crypto) of ok -> ok; _ -> exit(no_crypto) end." -noshell -s init stop`
+
+if test -n "$has_crypto"; then
+ AC_MSG_ERROR([Could not find the Erlang crypto library. Has Erlang been compiled with OpenSSL support?])
+fi
+
AC_PATH_PROG([ERLC], [erlc])
if test x${ERLC} = x; then