summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Lehnardt <jan@apache.org>2010-07-26 13:04:37 +0000
committerJan Lehnardt <jan@apache.org>2010-07-26 13:04:37 +0000
commitcd214b23e8129868d4a7020ddafd55a16e496652 (patch)
tree1d422d683815a79156b0b08ebf54e57a8270b86d /configure.ac
parent04f3d9892ba7a16b1431f07ac5dc031ff3bf285a (diff)
Check if Erlang has been compiled with crypto support at ./configure
time. Patch by Kev Jackson. Closes COUCHDB-106 and COUCHDB-131. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@979267 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c089523..1f0b7cf4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,6 +259,12 @@ if test `echo $version | ${AWK} "{print \\$2}"` -eq 6; then
fi
fi
+has_crypto=`${ERL} -eval "case application:load(crypto) of ok -> ok; _ -> exit(no_crypto) end." -noshell -s init stop`
+
+if test -n "$has_crypto"; then
+ AC_MSG_ERROR([Could not find the Erlang crypto library. Has Erlang been compiled with OpenSSL support?])
+fi
+
AC_PATH_PROG([ERLC], [erlc])
if test x${ERLC} = x; then