summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 35fd3de1..c7b766f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,7 +148,7 @@ if test x${ERL} = x; then
AC_MSG_ERROR([Could not find the `erl' executable. Is Erlang installed?])
fi
-erlang_version_error="The installed Erlang version is less than 5.6.0 (R12B)."
+erlang_version_error="The installed Erlang version is less than 5.6.5 (R12B05)."
version="`${ERL} -version 2>&1 | ${SED} "s/[[^0-9]]/ /g"`"
@@ -160,6 +160,12 @@ if test `echo $version | ${AWK} "{print \\$2}"` -lt 6; then
AC_MSG_ERROR([$erlang_version_error])
fi
+if test `echo $version | ${AWK} "{print \\$2}"` -eq 6; then
+ if test `echo $version | ${AWK} "{print \\$3}"` -lt 5; then
+ AC_MSG_ERROR([$erlang_version_error])
+ fi
+fi
+
AC_PATH_PROG([ERLC], [erlc])
if test x${ERLC} = x; then