summaryrefslogtreecommitdiff
path: root/bin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am37
1 files changed, 7 insertions, 30 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index b8b818cb..7d50d4e4 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -13,13 +13,13 @@
if WINDOWS
bin_SCRIPTS = couchdb.bat
else
-bin_SCRIPTS = couchdb couchjs
+bin_SCRIPTS = couchdb
endif
noinst_SCRIPTS = couchjs_dev
if HELP2MAN
-dist_man1_MANS = couchdb.1 couchjs.1
+dist_man1_MANS = couchdb.1
endif
CLEANFILES = $(bin_SCRIPTS) $(dist_man1_MANS) $(noinst_SCRIPTS)
@@ -48,27 +48,12 @@ couchdb: couchdb.tpl
$@ < $<
chmod +x $@
-couchjs: couchjs.tpl
- sed -e "s|%locallibbindir%|@locallibbindir@|g" \
- -e "s|%bug_uri%|@bug_uri@|g" \
- -e "s|%package_author_address%|@package_author_address@|g" \
- -e "s|%package_author_name%|@package_author_name@|g" \
- -e "s|%package_name%|@package_name@|g" \
- -e "s|%version%|@version@|g" \
- -e "s|%couchjs_command_name%|$(couchjs_command_name)|g" > \
- $@ < $<
- chmod +x $@
+install-exec-hook:
+ $(LN_S) -f "$(locallibbindir)/$(couchjs_command_name)" \
+ "$(DESTDIR)$(bindir)/$(couchjs_command_name)"
-couchjs_dev: couchjs.tpl
- sed -e "s|%locallibbindir%|$(abs_top_builddir)/src/couchdb/priv|g" \
- -e "s|%bug_uri%|@bug_uri@|g" \
- -e "s|%package_author_address%|@package_author_address@|g" \
- -e "s|%package_author_name%|@package_author_name@|g" \
- -e "s|%package_name%|@package_name@|g" \
- -e "s|%version%|@version@|g" \
- -e "s|%couchjs_command_name%|$(couchjs_command_name)|g" > \
- $@ < $<
- chmod +x $@
+couchjs_dev:
+ $(LN_S) -f "$(abs_top_builddir)/src/couchdb/priv/couchjs" "$@"
couchdb.bat: couchdb.bat.tpl
sed -e "s|%ICU_CONFIG%|$(ICU_CONFIG)|g" \
@@ -88,11 +73,3 @@ couchdb.1: couchdb.tpl.in
$(HELP2MAN_EXECUTABLE) $(HELP2MAN_OPTION) \
--name="Apache CouchDB database server" ./couchdb --output $@; \
fi
-
-couchjs.1: couchjs.tpl.in
- touch $@
- if test -x "$(HELP2MAN_EXECUTABLE)"; then \
- $(MAKE) -f Makefile couchjs; \
- $(HELP2MAN_EXECUTABLE) $(HELP2MAN_OPTION) \
- --name="Apache CouchDB JavaScript interpreter" ./couchjs --output $@; \
- fi