summaryrefslogtreecommitdiff
path: root/1.1.x/var/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '1.1.x/var/Makefile.am')
-rw-r--r--1.1.x/var/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/1.1.x/var/Makefile.am b/1.1.x/var/Makefile.am
new file mode 100644
index 00000000..901ab2b7
--- /dev/null
+++ b/1.1.x/var/Makefile.am
@@ -0,0 +1,23 @@
+## Licensed under the Apache License, Version 2.0 (the "License"); you may not
+## use this file except in compliance with the License. You may obtain a copy of
+## the License at
+##
+## http://www.apache.org/licenses/LICENSE-2.0
+##
+## Unless required by applicable law or agreed to in writing, software
+## distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+## WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+## License for the specific language governing permissions and limitations under
+## the License.
+
+install-data-hook:
+ if test ! "$(mkdir_p)" = ""; then \
+ $(mkdir_p) "$(DESTDIR)$(localstatelibdir)"; \
+ $(mkdir_p) "$(DESTDIR)$(localstatelogdir)"; \
+ $(mkdir_p) "$(DESTDIR)$(localstaterundir)"; \
+ else \
+ echo "WARNING: You may have to create these directories by hand."; \
+ mkdir -p "$(DESTDIR)$(localstatelibdir)"; \
+ mkdir -p "$(DESTDIR)$(localstatelogdir)"; \
+ mkdir -p "$(DESTDIR)$(localstaterundir)"; \
+ fi