summaryrefslogtreecommitdiff
path: root/test/etap/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2010-11-05 23:26:21 +0000
committerPaul Joseph Davis <davisp@apache.org>2010-11-05 23:26:21 +0000
commit11469d902b15145d361f9f7ec66a09ac3d04757c (patch)
tree3a75d566b2cc55173fa041b6b61ac61fa8c89e41 /test/etap/Makefile.am
parentc8785113522b8486fab0ba53f2043d94e9b1507f (diff)
HTTP proxy handler.
The second of two new features to replace the _externals protocols. This allows users to configure CouchDB to proxy requests to an external HTTP server. The external HTTP server is not required to be on the same host running CouchDB. The configuration looks like such: [httpd_global_handlers] _google = {couch_httpd_proxy, handle_proxy_req, <<"http://www.google.com">>} You can then hit this proxy at the url: http://127.0.0.1:5984/_google If you add any path after the proxy name, or make a request with a query string, those will be appended to the URL specified in the configuration. Ie: http://127.0.0.1:5984/_google/search?q=plankton would translate to: http://www.google.com/search?q=plankton Obviously, request bodies are handled as expected. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@1031877 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'test/etap/Makefile.am')
-rw-r--r--test/etap/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/test/etap/Makefile.am b/test/etap/Makefile.am
index 26c214d9..59d21cda 100644
--- a/test/etap/Makefile.am
+++ b/test/etap/Makefile.am
@@ -11,7 +11,7 @@
## the License.
noinst_SCRIPTS = run
-noinst_DATA = test_util.beam
+noinst_DATA = test_util.beam test_web.beam
%.beam: %.erl
$(ERLC) $<
@@ -27,6 +27,7 @@ DISTCLEANFILES = temp.*
EXTRA_DIST = \
run.tpl \
+ test_web.erl \
001-load.t \
002-icu-driver.t \
010-file-basics.t \
@@ -77,4 +78,6 @@ EXTRA_DIST = \
172-os-daemon-errors.4.es \
172-os-daemon-errors.t \
173-os-daemon-cfg-register.es \
- 173-os-daemon-cfg-register.t
+ 173-os-daemon-cfg-register.t \
+ 180-http-proxy.ini \
+ 180-http-proxy.t