summaryrefslogtreecommitdiff
path: root/test/etap/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2010-02-18 19:55:55 +0000
committerPaul Joseph Davis <davisp@apache.org>2010-02-18 19:55:55 +0000
commit0f3bc594c57d048d329708a6c91edf5bb5be3719 (patch)
tree8cf5a900df7fa783b8ce174dc5df57ead6bd750e /test/etap/Makefile.am
parent6c2f190d314c3894a9fddb4c1c3a65f5ddca3060 (diff)
Fixes COUCHDB-640 - Reset views with invalid update seqs.
If a database is restored to a previous version, and the view files are not updated appropriately they will contain data from the database after the reverted-to-update_seq. This patch checks that the update sequence recorded in a view is less than or equal to the update sequence of the database. Patch is by Filipe Manana. Execellent work once again. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@911544 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'test/etap/Makefile.am')
-rw-r--r--test/etap/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/etap/Makefile.am b/test/etap/Makefile.am
index 042c0bc2..2e302194 100644
--- a/test/etap/Makefile.am
+++ b/test/etap/Makefile.am
@@ -61,4 +61,8 @@ EXTRA_DIST = \
120-stats-collect.t \
121-stats-aggregates.cfg \
121-stats-aggregates.ini \
- 121-stats-aggregates.t
+ 121-stats-aggregates.t \
+ 130-attachments-md5.t \
+ 140-attachment-comp.t \
+ 150-invalid-view-seq.t
+