summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-11-09 00:39:16 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-11-09 00:39:16 +0000
commite29a1924afe9e6051369f7bcbf44ccdf53de536a (patch)
treee9511858c1ca8faf7b051c38b712982cb051caba /test/Makefile.am
parentc114565bff170785c1352142dc1a28557a91dd97 (diff)
Fixes 'make distcheck' to run the test suite.
Quite a few changes to the build system to handle VPATH builds appropriately as well as make the test suite know about them. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@833951 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am34
1 files changed, 1 insertions, 33 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index c2e705bb..4c4e54ea 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -10,37 +10,5 @@
## License for the specific language governing permissions and limitations under
## the License.
-dist_TESTS = runner.sh
+SUBDIRS = etap javascript view_server
-EXTRA_DIST = \
- etap/030-doc-from-json.t \
- etap/080-config-get-set.t \
- etap/064-kt-counting.t \
- etap/081-config-override.1.ini \
- etap/100-ref-counter.t \
- etap/083-config-no-files.t \
- etap/070-couch-db.t \
- etap/010-file-basics.t \
- etap/060-kt-merging.t \
- etap/040-util.t \
- etap/110-replication-httpc.t \
- etap/062-kt-remove-leaves.t \
- etap/001-load.t \
- etap/111-replication-changes-feed.t \
- etap/063-kt-get-leaves.t \
- etap/090-task-status.t \
- etap/021-btree-reductions.t \
- etap/081-config-override.2.ini \
- etap/065-kt-stemming.t \
- etap/020-btree-basics.t \
- etap/081-config-override.t \
- etap/082-config-register.t \
- etap/112-replication-missing-revs.t \
- etap/011-file-headers.t \
- etap/061-kt-missing-leaves.t \
- etap/050-stream.t \
- etap/031-doc-to-json.t \
- query_server_spec.rb \
- run_native_process.es \
- runner.sh \
- test.js