summaryrefslogtreecommitdiff
path: root/src/ibrowse/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-11-09 00:39:16 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-11-09 00:39:16 +0000
commite29a1924afe9e6051369f7bcbf44ccdf53de536a (patch)
treee9511858c1ca8faf7b051c38b712982cb051caba /src/ibrowse/Makefile.am
parentc114565bff170785c1352142dc1a28557a91dd97 (diff)
Fixes 'make distcheck' to run the test suite.
Quite a few changes to the build system to handle VPATH builds appropriately as well as make the test suite know about them. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@833951 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/ibrowse/Makefile.am')
-rw-r--r--src/ibrowse/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/ibrowse/Makefile.am b/src/ibrowse/Makefile.am
index 76262a6e..510f36a9 100644
--- a/src/ibrowse/Makefile.am
+++ b/src/ibrowse/Makefile.am
@@ -13,6 +13,7 @@
ibrowseebindir = $(localerlanglibdir)/ibrowse-1.5.2/ebin
ibrowse_file_collection = \
+ ibrowse.app.in \
ibrowse.erl \
ibrowse_app.erl \
ibrowse_http_client.erl \
@@ -21,9 +22,8 @@ ibrowse_file_collection = \
ibrowse_sup.erl \
ibrowse_test.erl
-ibrowseebin_static_file = ibrowse.app
-
ibrowseebin_make_generated_file_list = \
+ ibrowse.app \
ibrowse.beam \
ibrowse_app.beam \
ibrowse_http_client.beam \
@@ -33,16 +33,17 @@ ibrowseebin_make_generated_file_list = \
ibrowse_test.beam
ibrowseebin_DATA = \
- $(ibrowseebin_static_file) \
$(ibrowseebin_make_generated_file_list)
EXTRA_DIST = \
$(ibrowse_file_collection) \
- $(ibrowseebin_static_file) \
ibrowse.hrl
CLEANFILES = \
$(ibrowseebin_make_generated_file_list)
+%.app: %.app.in
+ cp $< $@
+
%.beam: %.erl
$(ERLC) $(ERLC_FLAGS) $<