summaryrefslogtreecommitdiff
path: root/src/ibrowse/Makefile.am
diff options
context:
space:
mode:
authorJohn Christopher Anderson <jchris@apache.org>2009-01-29 22:15:48 +0000
committerJohn Christopher Anderson <jchris@apache.org>2009-01-29 22:15:48 +0000
commitace6dfe0107010b57c5da0596f69cfd10fc84a38 (patch)
treebbcaedf64e20a580214f1b1f74cd40473073279c /src/ibrowse/Makefile.am
parent7cbee5abae38fca0c612e22bb1079641c96cd348 (diff)
Replacement of inets with ibrowse. Fixes COUCHDB-179 and enhances replication.
Thanks Jason Davies and Adam Kocoloski for the fix, Maximillian Dornseif for reporting. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@739047 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/ibrowse/Makefile.am')
-rw-r--r--src/ibrowse/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/ibrowse/Makefile.am b/src/ibrowse/Makefile.am
new file mode 100644
index 00000000..e4feb3d7
--- /dev/null
+++ b/src/ibrowse/Makefile.am
@@ -0,0 +1,47 @@
+## Licensed under the Apache License, Version 2.0 (the "License"); you may not
+## use this file except in compliance with the License. You may obtain a copy
+## of the License at
+##
+## http://www.apache.org/licenses/LICENSE-2.0
+##
+## Unless required by applicable law or agreed to in writing, software
+## distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+## WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+## License for the specific language governing permissions and limitations under
+## the License.
+
+ibrowseebindir = $(localerlanglibdir)/ibrowse-1.4.1/ebin
+
+ibrowse_file_collection = \
+ ibrowse.erl \
+ ibrowse_app.erl \
+ ibrowse_http_client.erl \
+ ibrowse_lb.erl \
+ ibrowse_lib.erl \
+ ibrowse_sup.erl \
+ ibrowse_test.erl
+
+ibrowseebin_static_file = ibrowse.app
+
+ibrowseebin_make_generated_file_list = \
+ ibrowse.beam \
+ ibrowse_app.beam \
+ ibrowse_http_client.beam \
+ ibrowse_lb.beam \
+ ibrowse_lib.beam \
+ ibrowse_sup.beam \
+ ibrowse_test.beam
+
+ibrowseebin_DATA = \
+ $(ibrowseebin_static_file) \
+ $(ibrowseebin_make_generated_file_list)
+
+EXTRA_DIST = \
+ $(ibrowse_file_collection) \
+ $(ibrowseebin_static_file)
+
+CLEANFILES = \
+ $(ibrowseebin_make_generated_file_list)
+
+%.beam: %.erl
+ $(ERLC) $<