summaryrefslogtreecommitdiff
path: root/src/couchdb/priv/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-08-18 04:27:07 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-08-18 04:27:07 +0000
commitb6947c0ba7c965de1614e491c37c8e0333de9e94 (patch)
treead77c7c24cd19343ed9936d71002163f4b033f53 /src/couchdb/priv/Makefile.am
parentcaeae66a3f428f2b4f4a3084cf6752bee77fb1b9 (diff)
Fixing make distcheck errors.
git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@805272 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/couchdb/priv/Makefile.am')
-rw-r--r--src/couchdb/priv/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/src/couchdb/priv/Makefile.am b/src/couchdb/priv/Makefile.am
index 5b4faae0..cfac5954 100644
--- a/src/couchdb/priv/Makefile.am
+++ b/src/couchdb/priv/Makefile.am
@@ -10,4 +10,27 @@
## License for the specific language governing permissions and limitations under
## the License.
-## This file intentionally left blank.
+couchprivdir = $(couchlibdir)/priv
+
+EXTRA_DIST = couchspawnkillable.sh
+
+couchpriv_PROGRAMS = couchspawnkillable
+if WINDOWS
+couchspawnkillable_SOURCES = couchspawnkillable_win.c
+endif
+
+if !WINDOWS
+couchspawnkillable: couchspawnkillable.sh
+ cp $< $@
+endif
+
+if WINDOWS
+install-data-hook:
+# libtool and automake have defeated markh. For each of our executables
+# we end up with 2 copies - one directly in the 'target' folder (eg, 'priv')
+# and another - the correct one - in .libs. The former doesn't work but is
+# what gets installed for 'couchspawnkillable' - but the correct one for
+# couchjs.exe *does* get copied. *shrug* So just clobber it with the
+# correct one here... See bug COUCHDB-439
+ $(INSTALL) .libs/couchspawnkillable.exe "$(DESTDIR)$(couchprivdir)/couchspawnkillable.exe"
+endif