summaryrefslogtreecommitdiff
path: root/src/couchdb/priv/Makefile.am
diff options
context:
space:
mode:
authorRobert Newson <rnewson@apache.org>2011-10-06 10:39:21 +0100
committerRobert Newson <rnewson@apache.org>2011-10-06 10:39:21 +0100
commit5b558c81ed9709fb286a6821e9ae6d6478012c2c (patch)
treedf5689ac2ecfda77d4129a4c814dc21f68b93653 /src/couchdb/priv/Makefile.am
parente6c0fc955ea2be0fd3c4e894fd0c7cc87202c5a5 (diff)
Remove SpiderMonkey 1.8.5 compatibility
This commit reverts 1.8.5 compatibility including the corresponding couchjs paren hack as this leads to significant breakage in existing functions.
Diffstat (limited to 'src/couchdb/priv/Makefile.am')
-rw-r--r--src/couchdb/priv/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/src/couchdb/priv/Makefile.am b/src/couchdb/priv/Makefile.am
index b55b5905..ae1b3e38 100644
--- a/src/couchdb/priv/Makefile.am
+++ b/src/couchdb/priv/Makefile.am
@@ -20,10 +20,7 @@ endif
EXTRA_DIST = \
spawnkillable/couchspawnkillable.sh \
- stat_descriptions.cfg.in \
- couch_js/sm170.c \
- couch_js/sm180.c \
- couch_js/sm185.c
+ stat_descriptions.cfg.in
CLEANFILES = $(dist_man1_MANS) stat_descriptions.cfg
@@ -50,14 +47,12 @@ COUCHJS_SRCS = \
couch_js/http.h \
couch_js/main.c \
couch_js/utf8.c \
- couch_js/utf8.h \
- couch_js/util.h \
- couch_js/util.c
+ couch_js/utf8.h
locallibbin_PROGRAMS = couchjs
couchjs_SOURCES = $(COUCHJS_SRCS)
couchjs_LDFLAGS = $(CURL_LDFLAGS)
-couchjs_CFLAGS = -g -Wall -Werror -D_BSD_SOURCE $(CURL_CFLAGS)
+couchjs_CFLAGS = -D_BSD_SOURCE $(CURL_CFLAGS)
couchjs_LDADD = $(CURL_LDFLAGS) @JSLIB@
couchpriv_DATA = stat_descriptions.cfg