summaryrefslogtreecommitdiff
path: root/src/couchdb/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-09-06 21:55:49 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-09-06 21:55:49 +0000
commite8769763ef6dd5e38bd458f00a42f531a953cc3c (patch)
treea054e4a96f0066182dfca97446ab1101fcfd2a1f /src/couchdb/Makefile.am
parent9f5c2be171c6964e4e05456833e742b0009bf029 (diff)
Fix for building CouchDB on Snow Leapord.
I was unable to track down the root cause of this bug, but for some reason, having -ljs in the link command for couch_erl_driver was causing a segfault when loading the latter in Erlang. This patch just removes -ljs from the global LIBS variable and places it specificially in the libs for couchjs. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@811910 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/couchdb/Makefile.am')
-rw-r--r--src/couchdb/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/couchdb/Makefile.am b/src/couchdb/Makefile.am
index 71b17f4a..017dc169 100644
--- a/src/couchdb/Makefile.am
+++ b/src/couchdb/Makefile.am
@@ -36,7 +36,7 @@ locallibbin_PROGRAMS = couchjs
couchjs_SOURCES = couch_js.c curlhelper.c curlhelper.h
couchjs_LDFLAGS = $(CURL_LDFLAGS)
couchjs_CFLAGS = $(CURL_CFLAGS)
-couchjs_LDADD = $(CURL_LDFLAGS)
+couchjs_LDADD = $(CURL_LDFLAGS) @JSLIB@
if WINDOWS
couch_erl_driver_la_LDFLAGS += -no-undefined