summaryrefslogtreecommitdiff
path: root/share/Makefile.am
diff options
context:
space:
mode:
authorJohn Christopher Anderson <jchris@apache.org>2009-08-11 18:50:08 +0000
committerJohn Christopher Anderson <jchris@apache.org>2009-08-11 18:50:08 +0000
commit36bbc72b6b0992639a0ba7a2077d75ec9f7cf03d (patch)
tree3e4e0d1e46a7fe04a9b185455a025e8ff5fa3e62 /share/Makefile.am
parentea95901fe52df11338134bd86f9bc8f028c5444b (diff)
Initial commit of _update handler. Thanks to Paul Davis, Jason Davies for code and others for discussion.
The _update handler accepts POSTs to paths like: /db/_design/foo/_update/bar and PUTs which include docids, like: /db/_design/foo/_update/bar/docid The function signature: function(doc, req) { doc.a_new_field = req.query.something; return [doc, "<h1>added something to your doc</h1>"]; } The tests in update_documents.js are fairly complete and include examples of bumping a counter, changing only a single field, parsing from (and returning) XML, and creating new documents. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@803245 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'share/Makefile.am')
-rw-r--r--share/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/share/Makefile.am b/share/Makefile.am
index 89ca9eb5..0fbf602f 100644
--- a/share/Makefile.am
+++ b/share/Makefile.am
@@ -137,6 +137,7 @@ nobase_dist_localdata_DATA = \
www/script/test/etags_head.js \
www/script/test/etags_views.js \
www/script/test/show_documents.js \
+ www/script/test/update_documents.js \
www/script/test/list_views.js \
www/script/test/compact.js \
www/script/test/purge.js \