summaryrefslogtreecommitdiff
path: root/share/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2010-02-18 19:55:55 +0000
committerPaul Joseph Davis <davisp@apache.org>2010-02-18 19:55:55 +0000
commit0f3bc594c57d048d329708a6c91edf5bb5be3719 (patch)
tree8cf5a900df7fa783b8ce174dc5df57ead6bd750e /share/Makefile.am
parent6c2f190d314c3894a9fddb4c1c3a65f5ddca3060 (diff)
Fixes COUCHDB-640 - Reset views with invalid update seqs.
If a database is restored to a previous version, and the view files are not updated appropriately they will contain data from the database after the reverted-to-update_seq. This patch checks that the update sequence recorded in a view is less than or equal to the update sequence of the database. Patch is by Filipe Manana. Execellent work once again. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@911544 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'share/Makefile.am')
-rw-r--r--share/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/share/Makefile.am b/share/Makefile.am
index 69f5baaf..5343801f 100644
--- a/share/Makefile.am
+++ b/share/Makefile.am
@@ -34,8 +34,10 @@ CLEANFILES = $(JS_FILE)
EXTRA_DIST = $(JS_FILE_COMPONENTS) $(JS_FILE_COMPONENTS_LAST)
+nobase_localdata_SCRIPTS = \
+ $(JS_FILE)
+
nobase_dist_localdata_DATA = \
- $(JS_FILE) \
www/config.html \
www/couch_tests.html \
www/custom_test.html \