summaryrefslogtreecommitdiff
path: root/etc/couchdb/Makefile.am
diff options
context:
space:
mode:
authorNoah Slater <nslater@apache.org>2008-04-14 23:15:55 +0000
committerNoah Slater <nslater@apache.org>2008-04-14 23:15:55 +0000
commitd33da1df789a4842269cb0945697320c1ff9d596 (patch)
treefa6e97f86ad5bbdb50f700950ea5aeb5c30578c9 /etc/couchdb/Makefile.am
parentb5c52f5814d88eb0135935761ed94fd4951d6c2a (diff)
removed non-standard use of .dist configuration files
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@648050 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'etc/couchdb/Makefile.am')
-rw-r--r--etc/couchdb/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/etc/couchdb/Makefile.am b/etc/couchdb/Makefile.am
index d5ccdb15..2835b9a9 100644
--- a/etc/couchdb/Makefile.am
+++ b/etc/couchdb/Makefile.am
@@ -10,4 +10,27 @@
## License for the specific language governing permissions and limitations
## under the License.
-## This file intentionally left blank.
+datarootdir = @prefix@/share
+
+pkgconf_DATA = couch.ini couch_httpd.conf
+
+nobase_dist_pkgconf_DATA = conf/mime.types
+
+CLEANFILES = $(pkgconf_DATA) $(dist_pkgconf_DATA)
+
+couch.ini: couch.ini.tpl
+ sed -e "s|%bindir%|@bindir@|g" \
+ -e "s|%pkgconfdir%|@pkgconfdir@|g" \
+ -e "s|%pkgdatadir%|@pkgdatadir@|g" \
+ -e "s|%pkgstatelibdir%|@pkgstatelibdir@|g" \
+ -e "s|%pkgstatelogdir%|@pkgstatelogdir@|g" \
+ -e "s|%couchprivlibdir%|$(couchprivlibdir)|g" \
+ -e "s|%couchjs_command_name%|$(couchjs_command_name)|g" \
+ < $< > $@
+
+couch_httpd.conf: couch_httpd.conf.tpl
+ sed -e "s|%pkgconfdir%|@pkgconfdir@|g" \
+ -e "s|%pkgdatadir%|@pkgdatadir@|g" \
+ -e "s|%pkgstatelogdir%|@pkgstatelogdir@|g" \
+ < $< > $@
+