summaryrefslogtreecommitdiff
path: root/etc/couchdb/Makefile.am
diff options
context:
space:
mode:
authorNoah Slater <nslater@apache.org>2008-06-07 16:26:43 +0000
committerNoah Slater <nslater@apache.org>2008-06-07 16:26:43 +0000
commit4dbe27108bb2ac6f84386c341a0355352b23fe78 (patch)
treed3909e9b1e1db6e804ad87ae614e2f8723ef221e /etc/couchdb/Makefile.am
parent39d8d02141d2864e300784377235b72e627ed9a3 (diff)
fixed double slash problems in configuration files
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@664363 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'etc/couchdb/Makefile.am')
-rw-r--r--etc/couchdb/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/etc/couchdb/Makefile.am b/etc/couchdb/Makefile.am
index 690bbb01..ed0d2faa 100644
--- a/etc/couchdb/Makefile.am
+++ b/etc/couchdb/Makefile.am
@@ -21,12 +21,18 @@ couchjs_command_name = `echo couchjs | sed '$(transform)'`
couchprivlibdir = $(erlanglibdir)/couch-$(version)/priv/lib
+abs_bindir = $(abspath $(bindir))
+abs_pkgdatadir = $(abspath $(pkgdatadir))
+abs_pkgconfdir = $(abspath $(pkgconfdir))
+abs_pkgstatelibdir = $(abspath $(pkgstatelibdir))
+abs_pkgstatelogdir = $(abspath $(pkgstatelogdir))
+
couch.ini: couch.ini.tpl
- sed -e "s|%bindir%|@bindir@|g" \
- -e "s|%pkgconfdir%|@pkgconfdir@|g" \
- -e "s|%pkgdatadir%|@pkgdatadir@|g" \
- -e "s|%pkgstatelibdir%|@pkgstatelibdir@|g" \
- -e "s|%pkgstatelogdir%|@pkgstatelogdir@|g" \
+ sed -e "s|%bindir%|$(abs_bindir)|g" \
+ -e "s|%pkgconfdir%|$(abs_pkgconfdir)|g" \
+ -e "s|%pkgdatadir%|$(abs_pkgdatadir)|g" \
+ -e "s|%pkgstatelibdir%|$(abs_pkgstatelibdir)|g" \
+ -e "s|%pkgstatelogdir%|$(abs_pkgstatelogdir)|g" \
-e "s|%couchprivlibdir%|$(couchprivlibdir)|g" \
-e "s|%couchjs_command_name%|$(couchjs_command_name)|g" \
< $< > $@