summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Lehnardt <jan@apache.org>2009-02-18 09:54:24 +0000
committerJan Lehnardt <jan@apache.org>2009-02-18 09:54:24 +0000
commitcd68c16d96bf9fc8a0eb2e6126b176b50a040a86 (patch)
tree51247c432b9b414166b80077bf0ba5acef46c90a /configure.ac
parentd778d2a96042dc06432c6abaea7da871b4dd4142 (diff)
Reorder LIB_FLAGS so JS_LIB_FLAGS can override defaults. Closes COUCHDB-170.
git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@745459 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 25ccebfe..a7c0b882 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,7 +76,7 @@ AC_ARG_WITH([js-lib], [AC_HELP_STRING([--with-js-lib=PATH],
AC_ARG_VAR([FLAGS], [general flags to prepend to LDFLAGS and CPPFLAGS])
-LIB_FLAGS="-L/usr/local/lib -L/opt/local/lib $JS_LIB_FLAGS"
+LIB_FLAGS="170$JS_LIB_FLAGS -L/usr/local/lib -L/opt/local/lib"
LIBS="$LIB_FLAGS $LIBS"
# XP_UNIX required for jsapi.h and has been tested to work on Linux and Darwin.
FLAGS="$LIB_FLAGS $ERLANG_FLAGS $JS_FLAGS -DXP_UNIX $FLAGS"