summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2011-10-23 12:27:35 -0500
committerPaul Joseph Davis <davisp@apache.org>2011-10-23 12:38:54 -0500
commitaf7a6ae52890c6c158615068f2a48d40c52ec538 (patch)
tree83efeef2dd1dc2ae9f2e857b0fc7ede0ecef2e56 /configure.ac
parent89f7faa6d09248999fb51ffd2a13777168f51805 (diff)
Hardcode couchjs binary name
Windows doesn't have the libgen.h header or an easily identified basename function. Instead of playing games we just configure the name with autoconf and run with that.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 182e0eb5..6a5d8653 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,7 +127,12 @@ Is the Mozilla SpiderMonkey library installed?])])])])])])])
AC_SUBST(JS_LIB_BASE)
+AC_DEFINE([COUCHJS_NAME], ["couchjs"], ["CouchJS executable name."])
+
if test x${IS_WINDOWS} = xTRUE; then
+
+ AC_DEFINE([COUCHJS_NAME], ["couchjs.exe"], ["CouchJS executable name."])
+
if test -f "$JS_LIB_DIR/$JS_LIB_BASE.dll"; then
# seamonkey 1.7- build layout on Windows
JS_LIB_BINARY="$JS_LIB_DIR/$JS_LIB_BASE.dll"