summaryrefslogtreecommitdiff
path: root/bin/Makefile.am
diff options
context:
space:
mode:
authorChristopher Lenz <cmlenz@apache.org>2008-03-28 23:32:19 +0000
committerChristopher Lenz <cmlenz@apache.org>2008-03-28 23:32:19 +0000
commit544a38dd45f6a58d34296c6c768afd086eb2ac70 (patch)
treec84cc02340b06aae189cff0dbfaee698f273f1f5 /bin/Makefile.am
parent804cbbe033b8e7a3e8d7058aaf31bdf69ef18ac5 (diff)
Imported trunk.
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@642432 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am79
1 files changed, 79 insertions, 0 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
new file mode 100644
index 00000000..c01d960e
--- /dev/null
+++ b/bin/Makefile.am
@@ -0,0 +1,79 @@
+## Licensed under the Apache License, Version 2.0 (the "License"); you may not
+## use this file except in compliance with the License. You may obtain a copy
+## of the License at
+##
+## http://www.apache.org/licenses/LICENSE-2.0
+##
+## Unless required by applicable law or agreed to in writing, software
+## distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+## WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+## License for the specific language governing permissions and limitations under
+## the License.
+
+datarootdir = @prefix@/share
+
+bin_SCRIPTS = couchdb couchjs
+
+if HELP2MAN
+dist_man1_MANS = couchdb.1 couchjs.1
+endif
+
+CLEANFILES = $(bin_SCRIPTS) $(dist_man1_MANS)
+
+transform = @program_transform_name@
+couchdb_command_name = `echo couchdb | sed '$(transform)'`
+couchjs_command_name = `echo couchjs | sed '$(transform)'`
+
+couchdb: couchdb.tpl
+ sed -e "s|%ERL%|$(ERL)|g" \
+ -e "s|%ICU_CONFIG%|$(ICU_CONFIG)|g" \
+ -e "s|%bindir%|@bindir@|g" \
+ -e "s|%erlangbindir%|@erlangbindir@|g" \
+ -e "s|%erlanglibdir%|@erlanglibdir@|g" \
+ -e "s|%pkgconfdir%|@pkgconfdir@|g" \
+ -e "s|%pkgstatelogdir%|@pkgstatelogdir@|g" \
+ -e "s|%pkgstatelibdir%|@pkgstatelibdir@|g" \
+ -e "s|%localstatedir%|@localstatedir@|g" \
+ -e "s|%list_address%|@list_address@|g" \
+ -e "s|%list_uri%|@list_uri@|g" \
+ -e "s|%package_author_address%|@package_author_address@|g" \
+ -e "s|%package_author_name%|@package_author_name@|g" \
+ -e "s|%package_name%|@package_name@|g" \
+ -e "s|%version%|@version@|g" \
+ -e "s|%couchdb_command_name%|$(couchdb_command_name)|g" > \
+ $@ < $<
+ chmod +x $@
+
+couchjs: couchjs.tpl
+ sed -e "s|%libbindir%|@libbindir@|g" \
+ -e "s|%list_address%|@list_address@|g" \
+ -e "s|%list_uri%|@list_uri@|g" \
+ -e "s|%package_author_address%|@package_author_address@|g" \
+ -e "s|%package_author_name%|@package_author_name@|g" \
+ -e "s|%package_name%|@package_name@|g" \
+ -e "s|%version%|@version@|g" \
+ -e "s|%couchjs_command_name%|$(couchjs_command_name)|g" > \
+ $@ < $<
+ chmod +x $@
+
+HELP2MAN_OPTION=--no-info --help-option="-h" --version-option="-V"
+
+# XXX: Because the scripts are made at bulid time for the user we need to
+# XXX: depend on the original templates so as not to cause the rebuilding of
+# XXX: the man pages.
+
+couchdb.1: couchdb.tpl.in
+ touch $@
+ if test -x "$(HELP2MAN_EXECUTABLE)"; then \
+ $(MAKE) -f Makefile couchdb; \
+ $(HELP2MAN_EXECUTABLE) $(HELP2MAN_OPTION) \
+ --name="Apache CouchDB database server" ./couchdb --output $@; \
+ fi
+
+couchjs.1: couchjs.tpl.in
+ touch $@
+ if test -x "$(HELP2MAN_EXECUTABLE)"; then \
+ $(MAKE) -f Makefile couchjs; \
+ $(HELP2MAN_EXECUTABLE) $(HELP2MAN_OPTION) \
+ --name="Apache CouchDB JavaScript interpreter" ./couchjs --output $@; \
+ fi