summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristopher Lenz <cmlenz@apache.org>2008-03-28 23:32:19 +0000
committerChristopher Lenz <cmlenz@apache.org>2008-03-28 23:32:19 +0000
commit544a38dd45f6a58d34296c6c768afd086eb2ac70 (patch)
treec84cc02340b06aae189cff0dbfaee698f273f1f5 /Makefile.am
parent804cbbe033b8e7a3e8d7058aaf31bdf69ef18ac5 (diff)
Imported trunk.
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@642432 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..aa07c7e7
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,60 @@
+## Licensed under the Apache License, Version 2.0 (the "License"); you may not
+## use this file except in compliance with the License. You may obtain a copy
+## of the License at
+##
+## http://www.apache.org/licenses/LICENSE-2.0
+##
+## Unless required by applicable law or agreed to in writing, software
+## distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+## WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+## License for the specific language governing permissions and limitations under
+## the License.
+
+datarootdir = @prefix@/share
+
+SUBDIRS = bin etc src share var
+
+pkgdoc_DATA = AUTHORS.gz BUGS.gz changelog.gz NEWS.gz README.gz THANKS.gz
+
+CLEANFILES = $(doc_DATA)
+
+DISTCLEANFILES = $(pkgdoc_DATA)
+
+EXTRA_DIST = AUTHORS BUGS ChangeLog NEWS README THANKS
+
+AUTHORS.gz: $(top_srcdir)/AUTHORS
+ -gzip -9 < $< > $@
+
+BUGS.gz: $(top_srcdir)/BUGS
+ -gzip -9 < $< > $@
+
+changelog.gz: $(top_srcdir)/ChangeLog
+ -gzip -9 < $< > $@
+
+NEWS.gz: $(top_srcdir)/NEWS
+ -gzip -9 < $< > $@
+
+README.gz: $(top_srcdir)/README
+ -gzip -9 < $< > $@
+
+THANKS.gz: $(top_srcdir)/THANKS
+ -gzip -9 < $< > $@
+
+local-clean: maintainer-clean
+ @echo "This command is intended for maintainers to use;"
+ @echo "it deletes files that may need special tools to rebuild."
+ rm -f COPYING
+ rm -f ChangeLog
+ rm -f INSTALL
+ rm -f acinclude.m4
+ rm -f aclocal.m4
+ rm -fr build-aux
+ rm -f config.h.in*
+ rm -f configure
+ rm -f configure~
+ rm -f couchdb-$(version).tar.gz
+ rm -f couchdb-$(version).zip
+ rm -fr m4
+ find . -name Makefile.in | grep -v 'src/js/fdlibm' | xargs rm
+
+.PHONY: local-clean