summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2015-09-03 21:26:58 -0400
committerKali Kaneko <kali@leap.se>2015-09-03 23:23:01 -0400
commitd1bbecdba0f65f726809989b3d5d323966bc3cc1 (patch)
treee6b98a3e84e816f5224f2213342b065ec2a2e40b /setup.py
initial commit
skeleton for module
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py95
1 files changed, 95 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..eef1541
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,95 @@
+# -*- coding: utf-8 -*-
+# setup.py
+# Copyright (C) 2013 LEAP
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+"""
+setup file for leap.bonafide
+"""
+import re
+from setuptools import setup, find_packages
+
+from pkg import utils
+
+# XXX TODO --- update to versioneer 0.15 ---------------------
+#import versioneer
+#versioneer.versionfile_source = 'src/leap/bonafide/_version.py'
+#versioneer.versionfile_build = 'leap/common/_version.py'
+#versioneer.tag_prefix = '' # tags are like 1.2.0
+#versioneer.parentdir_prefix = 'leap.bonafide-'
+# --------------------------------------------------------------
+
+parsed_reqs = utils.parse_requirements()
+
+
+trove_classifiers = [
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ ("License :: OSI Approved :: GNU General "
+ "Public License v3 or later (GPLv3+)"),
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.7",
+ "Topic :: Communications",
+ "Topic :: Security",
+ "Topic :: Utilities"
+]
+
+DOWNLOAD_BASE = ('https://github.com/leapcode/bonafide/'
+ 'archive/%s.tar.gz')
+
+#_versions = versioneer.get_versions()
+#VERSION = _versions['version']
+VERSION = '0.0.1'
+#VERSION_FULL = _versions['full']
+DOWNLOAD_URL = ""
+
+# get the short version for the download url
+#_version_short = re.findall('\d+\.\d+\.\d+', VERSION)
+#if len(_version_short) > 0:
+ #VERSION_SHORT = _version_short[0]
+ #DOWNLOAD_URL = DOWNLOAD_BASE % VERSION_SHORT
+#
+#cmdclass = versioneer.get_cmdclass()
+# ----------------------------------------------------------------
+
+try:
+ long_description = open('README.rst').read() + '\n\n\n' + \
+ open('CHANGELOG').read()
+except Exception:
+ long_description = ""
+
+setup(
+ name='leap.bonafide',
+ version=VERSION,
+ #cmdclass=cmdclass,
+ url='https://leap.se/',
+ #download_url=DOWNLOAD_URL,
+ license='GPLv3+',
+ author='The LEAP Encryption Access Project',
+ author_email='info@leap.se',
+ maintainer='Kali Kaneko',
+ maintainer_email='kali@leap.se',
+ description='Common files used by the LEAP project.',
+ long_description=long_description,
+ classifiers=trove_classifiers,
+ namespace_packages=["leap"],
+ package_dir={'': 'src'},
+ package_data={'': ['*.pem']},
+ packages=find_packages('src'),
+ test_suite='leap.bonafide.tests',
+ install_requires=parsed_reqs,
+ include_package_data=True,
+ zip_safe=False,
+)