summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d364f764..cc4871bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,7 @@
# Uncomment this to turn on verbose mode.
#DH_VERBOSE=1
DEB_BUILD_OPTIONS=nocheck
+package=bitmask
PYTHON2=$(shell pyversions -vr)
@@ -19,6 +20,7 @@ PYTHON2=$(shell pyversions -vr)
override_dh_prep:
rst2man docs/man/bitmask.1.rst docs/man/bitmask.1
dh_prep
+ # this will re-generate the resource files and locales.
make -f ./Makefile
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
@@ -49,11 +51,16 @@ install-python%:
# build and install sphinx docs
#
override_dh_installdocs:
- python setup.py build_sphinx
+# python setup.py build_sphinx
+ dh_installdocs
+
#COMMENTING OUT TO WORKAROUND THIS ERROR:
#dh_sphinxdoc: error: unknown JavaScript code: debian/bitmask/usr/share/doc/bitmask/html/_static/jquery.js
#dh_installdocs build/sphinx/html
+override_dh_installchangelogs:
+ dh_installchangelogs CHANGELOG
+
override_dh_auto_clean:
dh_auto_clean
rm -rf build