summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2016-04-01 12:55:00 -0400
committerKali Kaneko <kali@leap.se>2016-04-04 12:46:42 -0400
commitfe96e2eef29a538b856f0d8b4bbf3940e42364c1 (patch)
tree2a4356ee1770f483b6411d5e55603e087f28b012 /setup.py
parent9835bc05eaa0525df91a317c84f86b517ed57c73 (diff)
[pkg] update to versioneer 0.16
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 3 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 15327bf1..5bf5d186 100755
--- a/setup.py
+++ b/setup.py
@@ -26,6 +26,7 @@ import os
import re
from distutils.command.build import build as _build
+from setuptools import Command
if not sys.version_info[0] == 2:
print("[ERROR] Sorry, Python 3 is not supported (yet). "
@@ -84,11 +85,6 @@ if len(_version_short) > 0:
VERSION_SHORT = _version_short[0]
DOWNLOAD_URL = DOWNLOAD_BASE % VERSION_SHORT
-cmdclass = versioneer.get_cmdclass()
-
-
-from setuptools import Command
-
class freeze_debianver(Command):
@@ -99,7 +95,7 @@ class freeze_debianver(Command):
user_options = []
template = r"""
# This file was generated by the `freeze_debianver` command in setup.py
-# Using 'versioneer.py' (0.7+) from
+# Using 'versioneer.py' (0.16) from
# revision-control system data, or from the parent directory name of an
# unpacked source archive. Distribution tarballs contain a pre-generated copy
# of this file.
@@ -145,12 +141,12 @@ def freeze_pkg_ver(path, version_short, version_full):
with open(path, 'w') as f:
f.write(subst_template)
-
if sys.argv[:1] == '--sumo':
IS_SUMO = True
else:
IS_SUMO = False
+cmdclass = versioneer.get_cmdclass()
cmdclass["freeze_debianver"] = freeze_debianver
parsed_reqs = utils.parse_requirements()
@@ -263,7 +259,6 @@ cmdclass["hash_binaries"] = cmd_binary_hash
# sdist class need to augment the versioneer modified ones
-#_build = cmdclass['build_py']
versioneer_sdist = cmdclass['sdist']