summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorkali <kali@leap.se>2012-09-08 01:53:14 +0900
committerkali <kali@leap.se>2012-09-08 01:53:14 +0900
commit77f4686d43443d08f3b1bb1bb364d24dd127c8ce (patch)
tree49983966368de34adb553fffed5d6dcd00b31baa /setup.py
parent3fa754c39bcdea355a4ec6b0ddfaeead2040a86a (diff)
workaround for broken git version if no tag exists
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1e265cd5..47e28d53 100755
--- a/setup.py
+++ b/setup.py
@@ -33,10 +33,16 @@ trove_classifiers = [
"Topic :: Utilities"
]
+try:
+ version = version.get_git_version()
+except ValueError:
+ # workaround since that needs a tag.
+ version = "0.1.0"
+
setup(
name='leap-client',
package_dir={"": "src"},
- version=version.get_git_version(),
+ version=version,
description="the internet encryption toolkit",
long_description=(
"Desktop Client for the LEAP Platform."