summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorkali <kali@leap.se>2012-09-06 04:59:43 +0900
committerkali <kali@leap.se>2012-09-06 04:59:43 +0900
commit605717159e03b68105d708a153f668274d11daae (patch)
treec6e058d3ef5f9da5d4b0102837a2ce468fb224fe /setup.py
parentbb5d092b6f57321a12f0d7575e221b0cc68f063d (diff)
classifiers + long description
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py37
1 files changed, 31 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index ee082f88..d907ab58 100755
--- a/setup.py
+++ b/setup.py
@@ -15,21 +15,46 @@ except ImportError:
from setuptools import setup, find_packages
import os
-# get version from somewhere else
-version = '0.1'
+# XXX get version from somewhere else
+version = '0.1.0'
setup_root = os.path.dirname(__file__)
sys.path.insert(0, os.path.join(setup_root, "src"))
+trove_classifiers = [
+ "Development Status :: 3 - Alpha",
+ "Environment :: X11 Applications :: Qt",
+ "Intended Audience :: End Users/Desktop",
+ ("License :: OSI Approved :: GNU General "
+ "Public License v3 or later (GPLv3+)"),
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Topic :: Communications",
+ "Topic :: Security",
+ "Topic :: System :: Networking",
+ "Topic :: Utilities"
+]
+
setup(
name='leap-client',
package_dir={"": "src"},
version=version,
description="the internet encryption toolkit",
- long_description="""\
-""",
- classifiers=[], # Get strings from
- # http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ long_description=(
+ "Desktop Client for the LEAP Platform."
+ "\n"
+ "LEAP (LEAP Encryption Access Project) develops "
+ "a multi-year plan to secure everyday communication, breaking down"
+ "into discrete services, to be rolled out one at a time.\n"
+ "The client for the current phase gives support to the EIP Service."
+ "EIP (the Encrypted Internet Proxy) provides circumvention, location "
+ "anonymization, and traffic "
+ "encryption in a hassle-free, automatically self-configuring fashion, "
+ "and has an enhanced level of security."
+ ),
+ classifiers=trove_classifiers,
# XXX FIXME DEPS
# deps: pyqt