summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-09-04 17:14:17 +0200
committerKali Kaneko <kali@leap.se>2013-09-04 17:16:04 +0200
commit4da5d2ef7a6671c6f7f83a290c52441da5ac9873 (patch)
tree95eaf9399c3afb43180e2e1407ece63d63e9a455 /setup.py
parentd0afef400e3259b9b1d8acb7f53ee1eda380e9c0 (diff)
warn user if python3 is used to run setup
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7f2a5011..5099c1b1 100755
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,33 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
+# setup.py
+# Copyright (C) 2013 LEAP
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+"""
+Setup file for bitmask.
+"""
from __future__ import print_function
import sys
+if not sys.version_info[0] == 2:
+ print("[ERROR] Sorry, Python 3 is not supported (yet). "
+ "Try running with python2: python2 setup.py ...")
+ exit()
+
try:
from setuptools import setup, find_packages
except ImportError: