summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorkali <kali@leap.se>2012-10-24 04:25:46 +0900
committerkali <kali@leap.se>2012-10-24 04:25:46 +0900
commit205324734626a5dece03fc871448d0f71bbfb46d (patch)
tree9b81670ecb879d1db9729688f4df922a5b85e706 /setup.py
parent0060d3c74adce19fab7215b3788c5197cc05a9ae (diff)
removed branding info from branding config file
So we officially can say this is a generic client now. Branding config file is still at pkg/branding/config.py Note that with this change the package is called now leap-client so you will have to remove old installs of leap-foo-client in your path (from previous branded builds). Changing the package name was an AWFUL and painful idea, and we will not do that again. (launcher is another story). Lesson learned.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index e1566752..c280860d 100755
--- a/setup.py
+++ b/setup.py
@@ -187,8 +187,12 @@ class cmd_post_install(_install_data):
cmdclass = versioneer.get_cmdclass()
cmdclass["branding"] = DoBranding
-cmdclass["build"] = cmd_build
-cmdclass["sdist"] = cmd_sdist
+
+# Uncomment this to have the branding command run automatically
+# on the build and sdist commands.
+#cmdclass["build"] = cmd_build
+#cmdclass["sdist"] = cmd_sdist
+
cmdclass["install_data"] = cmd_post_install
@@ -196,7 +200,7 @@ launcher_name = branding.get_shortname()
if launcher_name:
leap_launcher = 'leap-%s-client=leap.app:main' % launcher_name
else:
- leap_launcher = 'leap=leap.app:main'
+ leap_launcher = 'leap-client=leap.app:main'
setup(
name=branding.get_name(),