summaryrefslogtreecommitdiff
path: root/pkg/osx/leap-client.spec
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2015-08-05 22:48:52 -0400
committerIvan Alejandro <ivanalejandro0@gmail.com>2015-08-07 19:02:24 -0300
commita688be4894e6f7bfc4dad414b2b4c0f747af945b (patch)
tree28339260f4938dee9fc80ebd59b4da277e8dee5e /pkg/osx/leap-client.spec
parentf220d32702eddbd18be167b2742bb60043f60a45 (diff)
[pkg] remove old files, update README a little
Diffstat (limited to 'pkg/osx/leap-client.spec')
-rw-r--r--pkg/osx/leap-client.spec36
1 files changed, 0 insertions, 36 deletions
diff --git a/pkg/osx/leap-client.spec b/pkg/osx/leap-client.spec
deleted file mode 100644
index 91aa20d6..00000000
--- a/pkg/osx/leap-client.spec
+++ /dev/null
@@ -1,36 +0,0 @@
-# -*- mode: python -*-
-a = Analysis(['../../src/leap/app.py'],
- pathex=[
- '../../src/leap',
- '/Users/kaliy/leap/leap_client/src/leap-client/pkg/osx'],
- hiddenimports=['atexit', 'leap.common'],
- hookspath=None)
-pyz = PYZ(a.pure)
-exe = EXE(pyz,
- a.scripts,
- exclude_binaries=1,
- name=os.path.join('build/pyi.darwin/leap-client', 'app'),
- debug=False,
- strip=True,
- upx=True,
- console=False)
-coll = COLLECT(exe,
- a.binaries +
- # this will easitly break if we setup the venv
- # somewhere else. FIXME
- [('cacert.pem', '/Users/kaliy/.Virtualenvs/leap-client/lib/python2.6/site-packages/requests-1.1.0-py2.6.egg/requests/cacert.pem', 'DATA'),
- ],
- a.zipfiles,
- a.datas,
- strip=True,
- upx=True,
- name=os.path.join('dist', 'app'))
-app = BUNDLE(coll,
- name=os.path.join('dist', 'leap-client.app'))
-
-import sys
-if sys.platform.startswith("darwin"):
- app = BUNDLE(coll,
- name=os.path.join('dist', 'LEAP Client.app'),
- appname='LEAP Client',
- version=1)