summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorkali <kali@leap.se>2012-08-09 02:11:08 +0900
committerkali <kali@leap.se>2012-08-09 02:11:08 +0900
commit646a917f43b21d9a6371194c67a4404cc6c3ef98 (patch)
tree12bd47b07d6c90ac64ce2f783158dd1764652a6c /debian/rules
parent90e53c5186f975e3c8b26f4cf8632e9c12984a6a (diff)
working deb again
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 10 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 8bbab3d8..152bc0d8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,39 +8,40 @@
#
#
-# needed??? no
+# needed??? no, should transition to use dhpython2
+# http://wiki.debian.org/Python/TransitionToDHPython2
+#
#DEB_PYTHON_SYSTEM=pysupport
+
# Uncomment this to turn on verbose mode.
#DH_VERBOSE=1
PYTHON2=$(shell pyversions -vr)
%:
- dh $@ --with python2
- #,sphinxdoc
+ dh $@ --with python2 --buildsystem=python_distutils #,sphinxdoc
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
# run tests!
#
test-python%:
- #python$* setup.py test -vv
- run.tests.sh
+ ./run_tests.sh
override_dh_auto_test: $(PYTHON2:%=test-python%) $(PYTHON3:%=test-python%)
endif
#dh_auto_build should be enough to build the python2 version
-#build-python%:
-# python$* setup.py build
+build-python%:
+ python$* setup.py build
#override_dh_auto_build: $(PYTHON3:%=build-python%)
# dh_auto_build
-#install-python%:
-# python$* setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
+install-python%:
+ python$* setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
#override_dh_auto_install: $(PYTHON3:%=install-python%)
# dh_auto_install