summaryrefslogtreecommitdiff
path: root/app/openvpn/src/plugins/down-root/Makefile.am
diff options
context:
space:
mode:
authorParménides GV <parmegv@sdf.org>2015-06-04 19:20:15 +0200
committerParménides GV <parmegv@sdf.org>2015-06-04 19:20:15 +0200
commit27594eeae6f40a402bc3110f06d57975168e74e3 (patch)
treecdabf6571e6f4ff07205fd6921d8095539a1fcdc /app/openvpn/src/plugins/down-root/Makefile.am
parent8dc4f58d96892fbfd83094fb85b1d17656035290 (diff)
ics-openvpn as a submodule! beautiful
ics-openvpn is now officially on GitHub, and they track openssl and openvpn as submodules, so it's easier to update everything. Just a git submodule update --recursive. I've also set up soft links to native modules from ics-openvpn in app, so that we don't copy files in Gradle (which was causing problems with the submodules .git* files, not being copied). That makes the repo cleaner.
Diffstat (limited to 'app/openvpn/src/plugins/down-root/Makefile.am')
-rw-r--r--app/openvpn/src/plugins/down-root/Makefile.am24
1 files changed, 0 insertions, 24 deletions
diff --git a/app/openvpn/src/plugins/down-root/Makefile.am b/app/openvpn/src/plugins/down-root/Makefile.am
deleted file mode 100644
index 7ca5a4e1..00000000
--- a/app/openvpn/src/plugins/down-root/Makefile.am
+++ /dev/null
@@ -1,24 +0,0 @@
-#
-# OpenVPN (TM) Down Root Plugin -- OpenVPN Plugin
-#
-# Copyright (C) 2012 Alon Bar-Lev <alon.barlev@gmail.com>
-#
-
-MAINTAINERCLEANFILES = \
- $(srcdir)/Makefile.in
-
-AM_CFLAGS = \
- -I$(top_srcdir)/include \
- $(OPTIONAL_CRYPTO_CFLAGS)
-
-if ENABLE_PLUGIN_DOWN_ROOT
-plugin_LTLIBRARIES = openvpn-plugin-down-root.la
-dist_doc_DATA = README.down-root
-endif
-
-openvpn_plugin_down_root_la_SOURCES = \
- down-root.c \
- down-root.exports
-openvpn_plugin_down_root_la_LDFLAGS = $(AM_LDFLAGS) \
- -export-symbols "$(srcdir)/down-root.exports" \
- -module -shared -avoid-version -no-undefined