summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko (leap communications) <kali@leap.se>2016-08-30 21:35:40 -0400
committerKali Kaneko (leap communications) <kali@leap.se>2016-08-30 21:35:40 -0400
commitb36b0501940fde2ff4a9f9e93ca4ff1a2e99719d (patch)
tree9251028557ae792a52116438574b3b49abd8a0ea /setup.py
parentcfebe6cf947ffad3c5f2a001323647665e025fa6 (diff)
[pkg] add setup
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py66
1 files changed, 66 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e69de29b..fe44737f 100644
--- a/setup.py
+++ b/setup.py
@@ -0,0 +1,66 @@
+"""
+Setup file for leap.bitmask
+"""
+from setuptools import setup, find_packages
+import versioneer
+
+# This requirements list is curated by hand. Here we can specify ranges.
+requirements = [
+ "twisted",
+ "colorama"]
+
+
+trove_classifiers = [
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: End Users/Desktop",
+ ("License :: OSI Approved :: GNU General "
+ "Public License v3 or later (GPLv3+)"),
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.7",
+ "Topic :: Communications",
+ 'Topic :: Communications :: Email',
+ "Topic :: Security",
+ 'Topic :: Security :: Cryptography',
+ "Topic :: Utilities"
+]
+
+DOWNLOAD_BASE = ('https://github.com/leapcode/bitmask-dev/'
+ 'archive/%s.tar.gz')
+
+VERSION = versioneer.get_version()
+DOWNLOAD_URL = DOWNLOAD_BASE % VERSION
+
+
+
+gui_launcher = 'bitmask=leap.bitmask.gui.app:start_app'
+bitmask_cli = 'bitmaskctl=leap.bitmask.cli.bitmask_cli:main'
+bitmaskd = 'bitmaskd=leap.bitmask.core.launcher:run_bitmaskd'
+
+
+setup(
+ name='leap.bitmask',
+ version=VERSION,
+ cmdclass = versioneer.get_cmdclass(),
+ url='https://leap.se/',
+ download_url=DOWNLOAD_URL,
+ license='GPLv3+',
+ author='The LEAP Encryption Access Project',
+ author_email='info@leap.se',
+ maintainer='Kali Kaneko',
+ maintainer_email='kali@leap.se',
+ description=("The Internet Encryption Toolkit: "
+ "Encrypted Internet Proxy and Encrypted Mail."),
+ long_description = open('README.rst').read(),
+ classifiers=trove_classifiers,
+ namespace_packages=["leap"],
+ package_dir={'': 'src'},
+ package_data={'': ['*.pem']},
+ packages=find_packages('src'),
+ install_requires=requirements,
+ include_package_data=True,
+ zip_safe=True,
+ entry_points={
+ 'console_scripts': [gui_launcher, bitmask_cli, bitmaskd]
+ },
+)