summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko (leap communications) <kali@leap.se>2016-10-28 10:17:38 +0200
committerKali Kaneko (leap communications) <kali@leap.se>2016-11-09 21:14:46 +0100
commit268d788ab083467247d2bd91e8ba71c0fc000e1e (patch)
tree34e7be0cc5382d3d09d2dfea7d31908f5bcc1bac /setup.py
parent981e4b6e66fc807fd36086e37296e40da914a0ff (diff)
[feature] serve UI as an hidden service
you need to configure onion = True in the services config. for sure, this is gonna be more interesting when we ship pixelated. but for now I thought it can be handy for testing ui changes: no need to bundle, just use your tor browser :) still need to try to serve imap/smtp over the onion service. kudos to meejah for this super-usable library!
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cf9a600b..da61958f 100644
--- a/setup.py
+++ b/setup.py
@@ -28,11 +28,13 @@ if platform.system() == "Windows":
mail_deps = ['leap.soledad.client', 'gnupg']
gui_deps = ['vext.pyqt5', 'leap.bitmask_js']
+tor_deps = ['txtorcon']
extras = {
'mail': mail_deps,
'gui': gui_deps,
'backend': mail_deps,
- 'all': mail_deps + gui_deps
+ 'all': mail_deps + gui_deps,
+ 'tor': tor_deps
}