summaryrefslogtreecommitdiff
path: root/pkg/pyinst/app.spec
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2017-06-19 17:01:58 -0700
committerKali Kaneko (leap communications) <kali@leap.se>2017-06-20 02:06:19 +0200
commit51011053093c87ca7ff2e024734578a5dce0dbfa (patch)
tree41246b001d1f1ac8717829bdef5a4e2b74ce26bd /pkg/pyinst/app.spec
parent70d424b2a0f873afd17dc493f46818a5658de954 (diff)
[pkg] add missing steps to produce a functional OSX bundle
Diffstat (limited to 'pkg/pyinst/app.spec')
-rw-r--r--pkg/pyinst/app.spec9
1 files changed, 8 insertions, 1 deletions
diff --git a/pkg/pyinst/app.spec b/pkg/pyinst/app.spec
index 4c9532be..f693432c 100644
--- a/pkg/pyinst/app.spec
+++ b/pkg/pyinst/app.spec
@@ -4,7 +4,13 @@ import sys
block_cipher = None
+IS_MAC = sys.platform.startswith('darwin')
+
BITMASK_VERSION = open('pkg/next-version').read()
+if IS_MAC:
+ # launchd chokes because more digits are added to the version string,
+ # so let's skip the patch part of the version.
+ BITMASK_VERSION = '.'.join(BITMASK_VERSION.split('.')[:-1])
hiddenimports = [
'appdirs',
@@ -17,6 +23,7 @@ hiddenimports = [
'leap.soledad.common',
'leap.soledad.common.document',
'leap.soledad.common.l2db',
+ 'leap.soledad.client.events',
'leap.bitmask_js',
'packaging', 'packaging.version', 'packaging.specifiers',
'packaging.requirements']
@@ -75,7 +82,7 @@ coll = COLLECT(exe,
upx=True,
name='bitmask')
-if sys.platform.startswith('darwin'):
+if IS_MAC:
app = BUNDLE(
coll,
name=os.path.join(