summaryrefslogtreecommitdiff
path: root/pkg/pyinst/app.spec
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2018-02-11 22:31:54 +0100
committerKali Kaneko <kali@leap.se>2018-02-15 16:36:42 +0100
commit03e4bae0942c58344d6021fdaa08342baa7aea3c (patch)
treee9cf6154c44016bdca3c98ed2a4c174b5fb8b972 /pkg/pyinst/app.spec
parentf5839b1938ba7ab96f0d9777520a564975470f51 (diff)
[feat] implement fallback to webkit for bundles
in the end, depending on webengine didn't seem to be such a great idea: it makes bundles more complex, heavy and brittle. I tried compiling qt5 and the maintained qtwebkit fork, but that had also its own set of problems (lastly, pyinstaller didn't work properly; pyqt also adds a lot of garbage even if you disabled lots of modules you don't need). so, this is a fallback to a stretch-based build. it fixes the libGL library by adding the right version into the bundle. in this commit I also add a dockerfile for an image that can build bundles by installing pip dependencies directly in the system. this has the advantage that the build process is very fast, but the downside that a new image needs to be pushed to the registry each time that new dependencies are added; we'll also miss any bug due to introducing new dependncies (but hopefully it will be catched by other steps in the CI). The good side of it is that it reduces the need for some hacks in the build process when bundling from a virtualenv.
Diffstat (limited to 'pkg/pyinst/app.spec')
-rw-r--r--pkg/pyinst/app.spec5
1 files changed, 2 insertions, 3 deletions
diff --git a/pkg/pyinst/app.spec b/pkg/pyinst/app.spec
index d00d540f..41fec22b 100644
--- a/pkg/pyinst/app.spec
+++ b/pkg/pyinst/app.spec
@@ -50,10 +50,9 @@ elif IS_MAC:
excludes = ['IPython', 'PySide']
else:
hiddenimports.extend(
- ['PyQt5.QtCore', 'PyQt5.QtGui', 'PyQt5.QtWebEngineWidgets',
+ ['PyQt5.QtCore', 'PyQt5.QtGui', 'PyQt5.QtWebKit', 'PyQt5.QtWebKitWidgets', 'PyQt5.QtPrintSupport',
'leap.bitmask.gui.icons_rc'])
- excludes = ['IPython', 'PySide',
- 'PyQt5.QtPrintSupport', 'PyQt5.QtNetwork.py']
+ excludes = ['IPython', 'PySide', 'PyQt5.QtNetwork.py']
VENV = os.environ.get('VIRTUAL_ENV', '')