summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2017-08-28 11:28:21 -0400
committerKali Kaneko <kali@leap.se>2017-09-01 17:18:20 -0400
commitffb51e40ae1ee1b0c0eeba4a9fe72ce3fec1f85a (patch)
tree1cee75a9daefa59a5ce2135315d0ce9d44424dc4 /debian/rules
parentacdc0362cf76b88b1bfb353caeee0c0d18c8ce58 (diff)
[pkg] bitmask-js package
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index e1e632d5..31b32567 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,7 @@ package=bitmask
PYTHON2=$(shell pyversions -vr)
# Prevent setuptools/distribute from accessing the internet.
+# but careful! node needs to unset this to get random crap from the intertubes.
export http_proxy = http://127.0.0.1:9
%:
@@ -28,10 +29,12 @@ override_dh_prep:
# this will re-generate the resource files and locales.
make -f ./Makefile qt-resources
+ # build the ui package
+ cd ui && make clean && make pydist-build
+
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
# run tests!
-#
#test-python%:
# xvfb-run ./run_tests.sh -x -N